PDA

View Full Version : Corsa auto with S light on dash


freddycougar
20-05-12, 04:32 PM
Mate of mine is looking at a corsa 1.4 auto off eblag. When you start the car from cold the "S" light stays on the dash and the car is slow to pull off, once warm it's fine. Any ideas? I figure it's the snow mode but what would probably be causing it?

2.0 vectra
20-05-12, 06:47 PM
selector switches are known for causing problems , sometimes just need a clean up .

freddycougar
21-05-12, 06:37 PM
Had this recently on a corsa, S light wouldn't go off & was flashing. Had a loook round it turned it all off & the light then stayed off.
Went to check the oil (as you do) Lo & behold the oil was brown, not because of it worn brown but some silly person had put engine oil in there,,,:thud: :hysterical: I told the guy he had to drop the oil & get new stuff, for gearbox, not engine... I did notice that bothe engine & gear dipsticks were next to eachother on these, & wondered how he topped up the engine oil,,,:rofl:

Haha - will tell him it's worth having a look at then. Switches I can do, oil change is a job for him. Car looks great bar that, so could well be converting a polo driver to vaux!

carlton_mad
21-05-12, 11:27 PM
im sorry to bring bad tidings but itll need more than a refill itll need a new box more than likely!!

carlton_mad
21-05-12, 11:31 PM
sorry mitch thought that was what the thread was about!! that is the one i was on about
as long as it hasnt been driven or run too long it may be possible to flush the box but i would take some advise from an auto box specialist first jm2pw!